Thursday, May 24, 2018

Dark Souls - REMASTERED - 3D-Vision-Fix - V1.10

*** This fix was made with 3D-Migoto V 1.3.8 - The game was nearly 3D-Ready out of the box, look @ the description for fixed issues***



Lastest Update: 01.06.2018 - V1.10

- fixes insane convergence that was set in d3d11.ini as default

Update: 24.05.2018 - V1.00
- release


Fixed:
- HUD
- water approx fix
- bonefire glossy "thing-issue"


Issues left:
- water not 100 % correct


Download - Fix V 1.00
Dark Souls - REMASTERED - 3D-Vision-Fix - V1.10


Introduction get it working:
- uninstall old fixes!!!
- download and extract the fix archive to the DarkSoulsRemastered.exe location

Ingame Settings:
- up to you

Key Settings:

Cycle HUD-Depth Presets
","
==> Find your matching HUD depth


Key Setting - Customization
if you dont like the settings the fix comes with, you have to find your own likes:
- choose your desired separation and convergence in the game (for the HUD you can cycle depth presets via Key (see key-settings)
- to see your convergence/separation set
[Hunting]
hunting=1
in d3d11.ini and press F10 to see the current separation/conv. Set it to 0 if finished (Press F10 again or resart the game) -- BE AWARE of pressing other keys of the NUM-PAD while hunting is enabled.
- Find a suitible HUD depth (constant "z")
- edit the section *Key definitions* in d3dx.ini and or constant "z = 0.3" in [Constants] section

Acknowledgements

- Big thanks to Bo3bDarkStarSword, Flugan and all others involved in creating 3DMigoto; an amazing wrapper that allows us to fix our favourite DX11 games in 3D Vision!
NVIDIA for creating 3D-Vision as a tech!
__________________________________________________________________________________
If you like the fix and want to contribute for more future fixes, you can donate to this PayPal account: rauti@inetmx.de

12 comments:

  1. You're the man, thanks for the quick fix.

    ReplyDelete
  2. Thank you very very much for this!!

    ReplyDelete
  3. This is not working for me unfortunately. The HUD and menus are fine, but the 3D renderings is clipping though walls, and the left/right have nothing to do with each other. Any advice?
    PS SLI does not work either.

    ReplyDelete
    Replies
    1. It works fine for me with sli, did you check the separation and lower it? It started insanely high for me so I had to lower it quite a bit.

      Delete
    2. Huh, I was setting up an insane convergence in the profile, sorry. You have to lower it, ill post an update to start the game with conv. 3.0 but i will work out a version with a more livebar depth for the target but have to check if this is suitible or not... SLI is working fine for me.

      You can edit the d3d11.ini file and set search for StereoConvergence and set it to StereoConvergence = 3 (or what ever or uncomment this line with ; )

      Delete
    3. Hi Losti, thanks for replying. It doesn't seem to be the StereoConvergence that's the problem. I've change this to 3 and to 1, and my 3D vision looks exactly the same. I've made two screenshots of the first scene of the game, one without 3D vision on, and same scene after pressing ctrl+t - I've uploaded to my onedrive
      - https://1drv.ms/f/s!Apal46TE2WmivzWtFR2tBiugNE2H

      I'm playing in TNB mode, but I've cycled through all modes and they're all the same. I've also tried not using SBS shader and still have the problem.

      RE SLI - I have tried with SLI disabled and enabled and am getting exactly the same FPS so it's definitely not working for me :(

      Delete
    4. I do not have any experiance with other modes than normal 3D-Stereo mode. May be this is a problem of the ini file. Please ofen the d3d11.ini and search for "x7 = 5" and change it to "x7 = 4". Than find ";run = CustomShader3DVision2SBS" and delete the ";" to uncomment this line. Try it. For SLI you can search for "StereoFlagsDX10 = 0x00004000" and set it to "StereoFlagsDX10 = 0x00000008"

      If run = CustomShader3DVision2SBS is uncommented you can switch the 3D stereo mode with F11 if you need.

      If the problem remains, please ask in the forum for help. You can also follow the instructuins given in the ini file that descripes the advice i have give you above again:

      "; The following custom shader can convert 3D Vision to Side-by-Side and
      ; Top-and-Bottom for use with 3D TVs & projectors - to enable this uncomment
      ; the 'run = CustomShader3DVision2SBS' in the [Present] section, set 3D Vision
      ; to output "checkerboard" in the control panel (which will remove the 720p
      ; limitation) and enable this either via the F11 key, or by setting a default
      ; for x7 in the [Constants] section. If you are using SLI and this isn't
      ; working properly (partially blank or stuck image) you may need to also set
      ; StereoFlagsDX10 = 0x00000008 in the [Profile] section."

      Delete
    5. Just use ctrl+F5 to low your convergence. It`s working fine here. Thanks for the fix

      Delete
  4. I was having a similar issue with clipping and crazy views, hitting period . fixes it for some reason

    ReplyDelete
  5. OK i have uploaded V 1.1 that fixes this convergence issue.

    ReplyDelete
  6. Still not fixed I have to press "." to be playable.

    Thanks,

    ReplyDelete
    Replies
    1. Hm, should be fixed because the problem was only a too high StereoConvergence setted in the ini in the profile for the game. Cured it using StereoConvergence = 3 instead. So if you have used the new ini from the update it should be fine….otherwhise pressing “.” Is not a problem I think ^^.

      Delete