Friday, May 4, 2018

STAR WARS Battlefront II (DX11)


Update July 6:
- Update HUD elements due game update


Thanks to murdavs and TimFx7 for donating the game!! really appreciate

Fix:
- Shadows / Lights
- CS Lights and Tile Lights
- Reflections
- Decals
- Lensflares
- HUD

TB and SBS Mode:
- The game support SBS/TB Mode using 3Dmigoto. Remove the ";" in the  ";include = ShaderFixes\3dvision2sbs.ini" of the d3dx.ini. Default TB Mode. F11 to cycle. Also remember to use "HDMI Checkerboard" in the NVCP to remove the 720p limitation.

Presets:
- Press F1 to see the keys available in this game.

Instructions:
- Extract where starwarsbattlefrontii.exe is located (\STAR WARS Battlefront II)
- Start the game, when "Rundll32" prompt appear, press "Yes" (in Win10 this don't appear). This is for the Profile Override needed for this game. In Nvidia overlay you will see "3Dfix by DHR".

Download

Screenshots

** Do you like the fix? **
If you like the fix, you can donate to this PAYPAL account: dhr.donation@gmail.com

37 comments:

  1. great DHR. Thanks a million. I m'going to buy the game. Thanks so much...

    ReplyDelete
  2. Thanks DRH. Terrific work!

    I noticed that some sparks are render in one eye. The sable laser of Skywalker is render in one eye too. Is possible to fix ??

    ReplyDelete
    Replies
    1. restart the game...happens to me a couple of time.
      Sable laser of skywalker is ok: http://photos.3dvisionlive.com/DHR/image/5aecc931e7e564a265000282/

      Delete
    2. This appears to be an issue with all frostbyte games. In DA:I and the original version this would happen between multplayer matches also. Such a pretty but shitty engine =)

      Delete
  3. Hello DHR. Thanks so much. Works great under windows 10 last nvidia drivers but I get some trouble with the weapon ...The 3D render is weird...like in "one eye"...Best regards.

    ReplyDelete
    Replies
    1. Happens to me a couple of times, restarting the game fix the issue....this is a common issue with frostbite3 engine, this happens to me in others frostbite3 games.

      Delete
  4. Great work ! ty so much ! btw, do we need to set postproccesing to low (disable refcletions on floors)? setting on medium/high/ultra reflections look wrong

    ReplyDelete
    Replies
    1. No, you can use any PP...I play with PP = ULTRA and don't have any issues with reflections. Look the screenshot posted here that have reflections all over the place.

      Delete
  5. mb this is different in sp, cause in mp they are a bit off, i need to check sp

    ReplyDelete
  6. F'n amazing DHR!!! Great work.. Made my day playing this in 3D. So next level!! Playing around now to see if I can get it work with SLI as it seems to crash unless I disable it (plays perfect when disabled). Haven't read up on it much yet, so I will see if there is any info out on the Nvidia forums on how to make SLI work. Such great work! Really is awesome. Love that you crazy smart dudes release fixes for us to enjoy. Will be making a donation

    ReplyDelete
  7. Hi guys, it appears the fix dont work anymore
    anyone having the same problem as me? it is all a mess now

    ReplyDelete
  8. same here, all lights messed up (one eye) and game crashes if fix is installed.

    ReplyDelete
    Replies
    1. I will check today night.....i see the games was updated, maybe something change.

      Delete
    2. I just check with the game updated and all is working fine. Maybe is some specific stage? i test a few.
      Also i'm playing in win7....maybe is a win10 issue.

      Delete
  9. Fix seems to be crashing game.

    ReplyDelete
    Replies
    1. Just test and i don't have crashes with the fix.

      Delete
    2. This comment has been removed by the author.

      Delete
  10. same here, game crash with fix. Both on win7 and 10

    ReplyDelete
    Replies
    1. I also tested this, and it was still working correctly for my system. Win7, latest Driver 398.11. No crash, 3D is correct.

      Delete
  11. Having some strange crashes with 3D in this game. Will run fine in 3D at 1920 x 1200. If I change the resolution higher in game options (1920 x 1440 or 2560 x 1440) it crashes. I have tried running the game in 2D changing reslolution to 2560 x 1440 then restarting in 3D, it crashes. Win 10, 399.24 drivers, Asus PG27VQ.

    ReplyDelete

  12. I am having the same issue. Crashes on start up. unable to get to the Screen menu. Window 10 playing @ 1440p.

    Thanks DHR.

    ReplyDelete
  13. First, thank you!
    Best 3D Vision experience! Looks so good.

    But the HUD is a bit broken since a update. As an example, the indication for the remaining tickets on a stage is not readable. Or some target indication for enemy ships on Hoth or Geonosis. Groupicons for the Squad and HUB for the skills too.
    The crosshair works fine.

    Thanks

    ReplyDelete
  14. Crashes game with latest build on Windows 10. I also have an Nvidia card.

    ReplyDelete
    Replies
    1. Doesn't look like this is related to our fix. I just tried this, and I get a crash as well. But it crashes even with no fix installed, and 3D disabled. Won't even run in 2D.

      Related thread.

      Delete
    2. Game seems to be pretty buggy. After doing a complete reinstall of the game from scratch, it's now working without crashing at launch. I still get crashes in-game, but that appears to be common.

      3D is working correctly, fix is working correctly. Driver 417.22, Win10 1803.

      Try reinstalling the game from scratch, after an uninstall of the game. I know it's 75G and a drag, but that was the only way I got it working. Delete the main game folder, and most likely the settings folder in Documents.

      Delete
  15. I have just installed it, and tried the fix (from 3DFixManager). The ingame 3D is very nice, but menus are all messed up, as it is the HUD too (except for crosshair). Is this normal/known or is it just my case?

    ReplyDelete
    Replies
    1. I'm playing through this game now, and I would say that the messed up HUD is normal. There are a lot of pieces to the HUD and pause menu UIs that are broken, but don't really impact the overall play. If it really bugs you, you could make a key override toggle to set convergence to zero (like ` key for example) for use when in menus.

      Delete
    2. Thanks. I have just tried what you suggests, it is a kind of workaround when moving through menus or even the pause menu, thanks, I did not thought on that. Still, it is impossible to aim in the 'air' combat missions (x-wing, etc), I thought that when the fix says HUD is fixed, that the in-game icons were fixed. I guess it is not possible or (maybe the last updates have broken the fix?).

      I like to play with big separation (near maximum of stock separation scale) and overall I find the HUD issues too distracting for me. I guess I'll keep playing this game in 2D for a while. A pity.

      Delete
    3. Not sure, seems OK to me. I'm about half-way through the campaign. I'm not playing MP.

      When I do the air combat I don't have any trouble. The crosshair and aim diamond seem to be at a fixed depth, not dynamic, but since they are both at the same depth, you only have to get your crosshair in the aim diamond and it kills them. Using torpedos is even easier, just have to be close to have it lock on.

      Other in-game HUD like the circles around G activation spots are maybe not at perfect depth, but also are pretty clear where they activate and don't have eye rivalry issues.

      What other in-game icons are you seeing that seem unplayable? Maybe make screenshots and post to Phereo, and I can tell if it's the same as what I'm seeing.

      Delete
    4. I have uploaded several screenshots to Phereo, these are the links:

      http://phereo.com/image/5c45cad8658b6ab504000033
      http://phereo.com/image/5c45caf6658b6a1a1f000009
      http://phereo.com/image/5c45cb7b658b6a8f71000030
      http://phereo.com/image/5c45cbac658b6a2c71000029
      http://phereo.com/image/5c45cc30658b6ab104000025
      http://phereo.com/image/5c45cc51658b6a8f71000031

      It is hard to get better shots in the air combat one. Tx!

      Delete
    5. Thanks for those snapshots. The broken GUI in pause/setting screens is what I see too. It's a real mess, but I think DHR made the right call here, it's not used often, and it's extremely tedious to get that working.

      For the last couple of shots while flying, my screens are different. Those diamond shape attack spots are screendepth for you, and they are depth for me. The lower right extras HUD is separated into pieces for you, and for me it's all one and still readable and not distracting.

      I'm playing Origin version, and now playing the real version, not the Trial. I had a *lot* of problems getting it running at all, and had to do a full reinstall from scratch. During that I found out that the EA updater is hopelessly broken, and creates damaged installations. Their 'Repair' tool is also pathetic, saying everything was fine, when even the directory structure was different.

      Maybe try two things.
      First, remove the fix with uninstall.bat, the run again and see if it seems the same. It might be that the fix is not working at all in your case.
      Second, uninstall the game, and reinstall from scratch. This is painful I know, because it's 75G of download, but it is a possible source of error.

      Delete
    6. Ops! Sorry I have posted my answer as new comment. I repeat it here, to keep in arranged. If possible, please, delete the other.

      Thanks for your comments and help! I was going to test it, and Origin has updated the game, now it does not even launch. I get a black screen for a moment and returns to desktop, no messages, nothing. Even in 2D with 3DVision disabled in NV Control Panel... It seems that this last update has broken the game...Will see if I wait to next update or if I try to fight out a solution.

      Delete
    7. Ok, the problem game not launching was, as in BF1, because after updating in Origin, there is still a new update (small, few megas) that even if downloaded and applied, it is not really applied, I have to do a clean boot of Win10 then apply this little update, reboot with all normal services activated and play. Now it launchs, but the problem is still there. I know the fix is there working, because I can change crosshair depth with p key, and F1 shows the hotkeys available… Still, no matter which crosshair depth I use, the problems described are always there (specially in the x-wing mission)...Uninstalled fix with bat file, and applied, no luck. I can redownload the whole thing, although I am not keeping my fingers crossed...

      Delete
    8. Thanks for the tip on the mini-update. I had same forced update to dead scenario. Freakin' EA Origin. Gaah.

      Played again here, and I'm wrong- the icons in the HUD are all messed up on the flying section, just like your pictures. The reason I didn't notice is because I had the convergence dialed so that it looked good to me, which happened to make the targeting circles at a good depth (I said diamonds above, those show up at screen depth, but you shoot the circles.)

      So, this is playable for me, if I dial the convergence and depth to put the circles at the same depth as the crosshair.

      Delete
    9. Well, at least I know I am not alone/suffering some particular behaviour. Thank you for confirmation, I'll try to adjust separation and convergence to make it bearable (together with a hotkey for menus). BTW, which separation are you using for this game (convergence, I can adjust it following the separation)?

      Delete
    10. Here's an example of what I see: http://phereo.com/image/5c4c1fbf658b6a8f71000061

      The diamonds are at screen depth and annoying, but they disappear most of the time. The targeting circles and my crosshair are set to 80% depth, which also makes it easier to focus past the screen depth pieces. I think that those diamonds can also be turned off in settings, but am unsure. On projector I play at 100% depth, but I think what really matters is depth of the crosshair, set with P key.

      Delete
  16. Thanks for your comments and help! I was going to test it, and Origin has updated the game, now it does not even launch. I get a black screen for a moment and returns to desktop, no messages, nothing. Even in 2D with 3DVision disabled in NV Control Panel... It seems that this last update has broken the game...Will see if I wait to next update or if I try to fight out a solution.

    ReplyDelete